Slow performance
Incident Report for SuperControl
Resolved
This incident has been resolved.
Posted 11 months ago. Apr 03, 2018 - 15:33 BST
Investigating
We are currently experiencing high traffic loads which is affecting the performance of SuperControl.
Posted 11 months ago. Apr 03, 2018 - 14:36 BST