Holiday Rent Payment - issues with processing payments
Incident Report for SuperControl
Resolved
This issue has now been resolved. Any failed payments will need to be re-attempted.
Posted Jun 16, 2022 - 09:24 BST
Identified
Holiday Rent Payment is reporting issues with their systems. This has been affecting payments since around 11pm last night (15 June).

Please see the Yapstone status page for updates https://status.yapstone.com/incidents/371377
Posted Jun 16, 2022 - 07:29 BST
This incident affected: SuperControl all systems.