PCI Proxy Platform Disruption

Incident Report for SuperControl

Resolved

This incident has been resolved.
Posted Jul 01, 2025 - 09:14 BST

Monitoring

PCI Proxy services have been restored as of 12:24 BST. We are actively monitoring payment processing and third-party integrations to ensure continued stability.

Impact:
Between 12:12 and 12:24 BST, clients may have experienced:
- Failed or delayed payment transactions
- Booking.com retrieval or sync issues
- Token-related API errors

Current Status:
- All services are now operational
- No further disruptions observed at this time
- We await the root cause analysis from PCI Proxy

Next Steps:
We’ll continue closely monitoring.
Posted Jun 23, 2025 - 12:31 BST

Investigating

We have been informed of a new incident on the PCI Proxy platform that may affect payment processing and third-party service integrations for SuperControl clients.

Current Status:
PCI Proxy has acknowledged the issue, and their team is actively investigating. We are monitoring the situation and will provide further updates as they become available.

Potential Impact:
- Disruption to payment gateway access
- Booking.com sync or update failures
- Delays in secure token-based transactions

Next Update:
As soon as further information is released by PCI Proxy or observed through our monitoring.
Posted Jun 23, 2025 - 12:23 BST
This incident affected: SuperControl all systems.