Disruption to PCI Proxy Services Impacting Payment Processing

Incident Report for SuperControl

Resolved

This incident has been resolved.
Posted Jun 21, 2025 - 06:53 BST

Monitoring

Overview:
The earlier issue affecting PCI Proxy — which impacted payment processing and Booking.com data retrieval in SuperControl — has now been resolved.

Resolution Details:
Start Time: June 20th, 10:09:59 CET (09:09:59 BST)
End Time: June 20th, 11:02:59 CET (10:02:59 BST)
Current Status: All services are now operating normally.

Next Steps:
PCI Proxy has confirmed that they are conducting a full internal review. We will share a summary of their findings as soon as it becomes available.

Thank You:
Thank you for your patience while the issue was resolved. Please contact our support team should you be experiencing any issues.
Posted Jun 20, 2025 - 10:15 BST

Identified

Overview:
Our upstream provider, PCI Proxy, is currently experiencing a service disruption. This affects SuperControl’s ability to communicate with third-party payment processors and services that rely on PCI Proxy for secure tokenisation.

Impact:
Some SuperControl users may encounter issues when attempting to process payments or communicate with external gateways (e.g. Opayo, TrustPayments, HRP, etc.).
Tokenised payment data and third-party card interactions may be temporarily unavailable.
Booking.com Integration: Bookings retrieved from Booking.com are temporarily inaccessible. This includes delays in receiving reservation data and payment card information.
Other third-party services that require PCI Proxy access may also be affected.

Timeline:
09:16 BST – PCI Proxy reported an issue with their platform.
09:40 BST – Investigation ongoing. Awaiting root cause analysis from PCI Proxy’s engineering team.

Next Steps:
We are monitoring the situation closely and will continue to liaise with PCI Proxy.
Updates will be provided as soon as further information becomes available or the issue is resolved.

What You Can Do:
No action is required at this time. We recommend delaying any non-urgent payment actions until the issue is confirmed as resolved.

We appreciate your patience and will keep you informed with timely updates.
Posted Jun 20, 2025 - 09:55 BST
This incident affected: SuperControl all systems and UpFrontReviews.