We are currently investigating an issue affecting access to SuperControl services.

Incident Report for SuperControl

Update

We are continuing to investigate the ongoing issue affecting access to SuperControl services.

At this time there is no further update, however our teams remain actively engaged and working to restore normal service as quickly as possible.

We appreciate your patience and apologise for the continued disruption.
Posted May 25, 2026 - 19:43 BST

Update

We are continuing to investigate this issue.
Posted May 25, 2026 - 18:34 BST

Investigating

We are currently investigating an issue affecting access to SuperControl services.

Our team is actively working to identify the cause and restore service as quickly as possible.

We apologise for the disruption and will provide further updates as soon as more information becomes available.
Posted May 25, 2026 - 18:33 BST
This incident affects: SuperControl all systems.