Holiday Rent Payment Outage

Incident Report for SuperControl

Resolved

This incident has been resolved.
Posted Feb 10, 2026 - 20:13 GMT

Update

The issue has now been resolved.

The Holiday Rent Payment technical team identified and corrected the problem approximately 10 to 15 minutes ago. The issue was caused by a database update.

Payments should now be processing normally. Please let us know if you experience any further issues. We will continue to monitor the situation.
Posted Feb 10, 2026 - 14:15 GMT

Monitoring

Payments are now processing again.

We are awaiting further details from the Holiday Rent Payment technical team on the cause of the issue and will share an update once this information is available.
Posted Feb 10, 2026 - 14:12 GMT

Investigating

We are currently investigating an issue with Holiday Rent Payment. At present, payments are failing.

The Holiday Rent Payment technical team are aware of the issue and are actively investigating. We will provide an update as soon as more information is available.
Posted Feb 10, 2026 - 13:56 GMT
This incident affected: SuperControl all systems.