Unspecified issues
Incident Report for SuperControl
Resolved
We are back fully operational.
Posted Jan 03, 2024 - 16:44 GMT
Investigating
We are experiencing unspecified issues resulting in problems with our application.
Our technical team are currently working on finding the cause of the problem.
Posted Jan 03, 2024 - 15:30 GMT
This incident affected: SuperControl all systems.