Issues with HRP payments for grouped properties.
Incident Report for SuperControl
Resolved
This incident has been resolved.
Posted Mar 05, 2024 - 07:19 GMT
Investigating
Some clients experience issues regarding problems with HRP payments for grouped properties. We are investigating it.
Posted Mar 04, 2024 - 14:40 GMT
This incident affected: SuperControl all systems.