PCI Proxy reports that services are now operational. We are monitoring payment and integration functionality closely to ensure complete stability.
Impact: - All core functionality is currently restored. - No client action is required unless issues persist.
Next Steps: A full incident report will be shared once PCI Proxy completes its investigation.
Posted Jun 23, 2025 - 09:02 BST
Identified
PCI Proxy has identified the issue affecting payment processing and third-party integrations. Services are operational, but investigations are ongoing to determine the root cause.
Impact for SuperControl Clients: - Temporary disruption to payment transactions - Potential delays in Booking.com and other token-based operations
Next Steps: We continue to monitor the situation closely and will share further updates once PCI Proxy completes its investigation.
Posted Jun 23, 2025 - 09:00 BST
Investigating
We are currently experiencing issues with payment processing and third-party integrations due to an active incident on the PCI Proxy platform. This may affect:
- Payment authorisation or processing - Booking.com booking retrieval or confirmation - Any features that depend on PCI Proxy tokenisation
Current Status: PCI Proxy is investigating the issue. We are monitoring it closely and will provide updates as soon as we have them.
Impact for SuperControl Clients: You may notice:
- Failures in payment gateway connections - Errors retrieving external bookings or pushing updates - Incomplete or delayed transactions
Next Update: We will share further updates as soon as PCI Proxy publishes more details.